Wink Issue.

Wink setup, hardware, basic programming. User to user support.
Posts: 3
Joined: Thu Jan 21, 2016 2:18 pm

Wink Issue.

Postby kushagrgoyal » Thu Jan 21, 2016 4:39 pm

i received my wink recently. i am on macbook air, mac 10.11.2 and am using the latest arduino IDE 1.6.7 and the latest FTDI 2.3 drivers.

The issue i am facing is:
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

this goes on for 10 attempts and then it stops. the port i see is "/dev/cu.usbserial-DA01HH35"

I've tried following things to make it work:
1. switching out usb cables.
2. reinstalling all the drivers.

I am not sure if the programmer is faulty or its a driver issue. the charging led turns on on wink when connected, and while it attempts to upload the sketch, the led for RX blinks every time a 'new attempt' is made. i couldnt get it to work with answers in previous posts, can anyone please help????



Posts: 32
Joined: Sun Feb 07, 2016 6:10 am

Re: Wink Issue.

Postby wclift » Sun Feb 07, 2016 6:35 am

I just got my pair of Winks today and was really excited to get started. I had never used Arduino stuff before, so I knew there would be a bit of a ramp. And the Wink web info still points to a lot of Ringo stuff, and there are some hardware differences. I got drivers, then IDE, then libraries, then code examples all installed successfully. Computer (and later a laptop) both recognized the COM port when the Wink was plugged in. I could code and compile my first program. Then in excitement, I tried to upload and got the now familiar avrdude messages. I then spent the next 5 hours swapping out computers, cables, listening to videos, etc. Even after I thought I finally knew enough, I could not get the upload to work.

Fortunately, by sheer luck, probably, I suddenly saw my Wink doing what I asked it after trying a final upload. I was shocked. After some educated guess, and confirmed by trying this on the second computer and both Winks with different cables, I have discovered the pieces of information that were not obvious and absolutely critical.

For my brand new Wink Rev4 and Programmer Rev5:
1) Arduino IDE -> Tools -> Board -> Arduino Fio (not Genuino Uno, despite docs saying this is an uno board)
2) Arduino IDE -> Tools -> Port -> <com#> (your new COM port, identifiable by disconnect/connect cable)
3) Push WINK power button! (Wink will chirp and then begin running last program)
4) Hit Upload.

I spent 3 hours discovering #3 the hard way. Unlike Ringo, which has a slider ON switch, the Wink has a flush purple button on its back left. Even though the charge light may be on when all plugged in, Wink is NOT ON! And if it isn't on, the avrdude messages tell you it can't talk to the Wink. You think it's on, but it's not. If you already hit upload and it's in the retry period, it has to finish, or you have to unplug and plug and stop everything, then turn wink on, then upload.

I found no way to turn Wink on without it actually running the last program. I hadn't been doing it because it would run the demo program that had it skittering everywhere. I had thought and hoped that the power button would turn on and then the right button would be the "go" button. Perhaps I'll figure out how to have my programs do that soon.

So, biggest learnings...Arduino Fio and push on button!

Who is online

Users browsing this forum: No registered users and 6 guests