Overheating wink wont turn on

Wink setup, hardware, basic programming. User to user support.
JCH
Posts: 3
Joined: Sun Apr 17, 2016 11:12 am

Overheating wink wont turn on

Postby JCH » Mon May 02, 2016 6:18 pm

Well I've finally decided to play around with the wink and its overheating and wont turn on and wont allow me to upload code.

I've done everything by the book using it for a half an hour and changing the code and now its so hot burns touching it mainly at the battery casing and the main chip underneath the battery.

Is there anything wrong with my wink?
Is it just the heat causing resistance so it wont work until it cools down?
Why has it gotten so hot? I hasn't been plugged in much and the code is all code as I verified it.

It works when you let it cool down but at some points gets way to hot.

User avatar
sil
Posts: 39
Joined: Thu Oct 01, 2015 1:04 am

Re: Overheating wink wont turn on

Postby sil » Sun May 08, 2016 8:52 pm

Definitely NOT normal behaviour! I have had my Ringo running a circuit for over an hour until its battery was flat with no warmth at all. Lithium batteries are horribly unstable, you may have heard of laptops bursting into flames on the news at times, they provide a great power output at the cost of a limited lifespan. The batteries in Wink and Ringo shouldn't be old but perhaps yours is a slightly defective one or maybe a poor solder connection or short exists. If you still have its antistatic bag I suggest putting it away, contacting Plumgeek support immediately and follow their advice. An overheating lithium battery is a genuine fire risk so unplug it and contact Plumgeek.

Kevin
Posts: 129
Joined: Tue Jul 28, 2015 12:56 am

Re: Overheating wink wont turn on

Postby Kevin » Tue May 10, 2016 9:06 pm

Hey JCH-

We spoke via email but wanted to let you know here also I packed up a replacement unit and got it ready to ship as soon as I saw this yesterday morning. This is definitely not normal.

There are 2 protection circuits to prevent this and I've not heard of a battery getting hot so far.

There is a resettable fuse that will open at around 300 mA current and will reset after a few minutes after the short is removed. Also there is an IC that monitors and limits current to all the high load items - the motors, eyes, lights, etc. The only thing not on that load limited line is the processor itself, so even if there were a dead-short on the eye for example, this IC would stop current and it just wouldn't light up.

We'll continue to follow up via email to see if we can figure out what happened. It's going to be too costly to ship it back over the pond but maybe we can identify something via pictures. I'm just curious to know for myself exactly what happened.

jillb327
Posts: 1
Joined: Thu Jan 05, 2017 6:05 pm

Re: Overheating wink wont turn on

Postby jillb327 » Thu Jan 05, 2017 6:10 pm

I am having the same overheating problem with my Wink. The initial test run of it went smoothly but when I plugged it into the USB drive on my computer, it began to overheat and the power wouldn't come on. Is there a next step you would recommend?

Kevin
Posts: 129
Joined: Tue Jul 28, 2015 12:56 am

Re: Overheating wink wont turn on

Postby Kevin » Sat Jan 07, 2017 5:57 pm

Hello jill-

We've recently got to the bottom of what is happening when this occurs. We've had isolated examples of this happening and were never able to recreate the problem but we've got it figured out now. This getting hot issue happens when the ribbon cable is connected incorrectly. If it is connected upside down and at the same time is only connected to the top row of pins on the robot, this will happen.

We've recently published an advisory on our website about this. The problem can be avoided by clipping a couple pins on the programmer, but unfortunately the damage once done is permanent. Contact me through the contact form on our website and we'll work with you to get it repaired. The damaged part is easy for us to replace.

Here's a link to the advisory:
http://www.plumgeek.com/programmer-advisory.html

Sorry for the trouble but follow up with me and we'll get it resolved.

Thanks!
-Kevin


Who is online

Users browsing this forum: No registered users and 1 guest