Page 1 of 1

Raspberry Pi doesn't start

Posted: Mon Mar 12, 2018 8:52 am
by Marcel-Jan
This weekend I had some time, so I thought "today I will get the weels running with Python". Instead this happened:

I followed these instructions directly while connected to my Raspberri Pi: http://forum.plumgeek.com/viewtopic.php?f=18&t=6575
I ran raspi-config and tried Expand Filesystem, but that didn't work. I suppose because it was already expanded?
Then I enabled SPI and I2C.
Then I ran sudo apt-get update and sudo apt-get upgrade and... it didn't start anymore.
I was able to start Raspberry Pi in safe mode, where I got to NOOBS, but even reinstalling the Raspberry Pi didn't work. It crashes almost immediately when it starts writing to ext4.

Is this recoverable somehow? It doesn't look good.

Re: Raspberry Pi doesn't start

Posted: Mon Mar 12, 2018 1:07 pm
by marckarasek
This does not sound like it is recoverable.

What size SD card are you using? I would use a min of 16GB now. As the base image will fit ina 8 GB part but once you start adding things and updating (it has to d/l the updates and then apply them) it can eat up the space. I had an issue of runnging out of space on the card and went to a 16GB card.

To answer your question yes the rasp pi will automatically extend the filesystem.

NOTE: Once you get it all up and running and have the image the way you want it. Pull the SD card out of the Rover and use windisk32 to make a backup copy of the image. This way if things go bad you can always recover w/o having to set it all back up again.

Marc

Re: Raspberry Pi doesn't start

Posted: Tue Mar 13, 2018 3:54 pm
by Marcel-Jan
Any way I can start anew? Is there an image somewhere that I can download?

Re: Raspberry Pi doesn't start

Posted: Wed Mar 14, 2018 6:03 pm
by tvoverbeek
You do not need NOOBS, but can download a Raspbian image from the Raspberry Pi site: https://www.raspberrypi.org/downloads/raspbian/
Use Etcher to burn the image to your SD card. See https://www.raspberrypi.org/documentation/installation/installing-images/README.md.
On first boot the filesystem will be expanded and the Pi will reboot automatically.
Hence the first boot can take some time.

Good luck/Veel succes