Page 1 of 1

Pan Servo Not Working

Posted: Mon Apr 02, 2018 12:22 am
by ddobrien2
I'm helping my 11 year old build the Spirit. We just did the Center Servos step - The Grip and Pan servos both moved during the test, but the Pan servo isn't moving. I've checked and doublechecked the assembly/connections. I'm 99% sure we've got it correct.

For those of you with more experience - is this likely a bad servo, an issue with the connection or something else? Suggested next steps or things to try?

Thanks for any suggestions.

Re: Pan Servo Not Working

Posted: Mon Apr 02, 2018 2:00 am
by TomTheWhittler
I pulled the wires out to show my pan connection. If I remember correctly it was a little confusing in the assembly manual.
It is possible that the servo is bad. You could plug in the tilt servo to see if it is the servo or the board.
Pan.jpg
(32.16 KiB) Not downloaded yet

Re: Pan Servo Not Working

Posted: Mon Apr 02, 2018 2:24 am
by ddobrien2
Thank you. I did swap the Pan and Tilt wires. At which point, the Tilt Servo did turn, and the Pan did not (again). So I would guess that it's as simple as a bad Servo. Although it doesn't look like it'll be simple to replace (will have to undo quite a few step - oh well). Any suggestions on the process of getting a replacement? In terms of specs, etc., that will work/fit? I see many on line that look identical. But unsure if I need to be more exacting.

Re: Pan Servo Not Working

Posted: Mon Apr 02, 2018 9:37 am
by TomTheWhittler
It seems like the Servo is bad. Since you have to dissect to remove the servo you might as well take the servo apart once you get it out. Sometimes they are fixable. Only 4 screws hold them together. It could be as simple as the motor brush is not touching. Only two tangs hold the motor brushes back plate on. There are several YouTube videos on servo repair. Since it is dead anyway my attitude is "nothing ventured, nothing gained." Chances are Kevin will sent you a new servo for free if it is dead.