Page 2 of 7

Re: Serial port not showing up.

Posted: Fri Aug 14, 2015 12:00 pm
by PeteM

I have a MacBook Air running Yosemite latest version. I don't think it's your cable as I've used a number of different cables without issue. I think it's your FTDI driver. Go to the site and search for Document Reference No.: FT_000201 which is the load instructions for Macintosh. Read through the PDF and it shows 3 drivers for the Mac depending on which version of the OS you have. You'll want FTDIUSBSerial.pkg which is specific for Mavericks and Yosemite.


Re: Serial port not showing up.

Posted: Fri Aug 14, 2015 2:04 pm
by trent
I am having this problem with a standard USB A to Mini-B cable. Tried a couple different ones with no success. Possibly a problem with the Programming Adaptor?

Re: Serial port not showing up.

Posted: Fri Aug 14, 2015 2:12 pm
by talasinski

I have succeeded in programming the Ringo on a Mac (10.10.4&5) using the SparkFun Cerberus USB Cable form While I can't prove that the issue is a cable problem, I know there is at least one cable that works.

I used the Driver recommended by Ringo (FTDIUSBSerialDriver_v2_3.dmg). On the other hand I have an old robot using BT/ATmega168 to which I can't connect. There are still issues with Drivers on the latest Mac OS's.


Re: Serial port not showing up.

Posted: Sat Aug 15, 2015 12:05 am
by MTBguy
I am having the same problem. I am running Linux Mint 17.1. I have tried 6 or 7 different cables to no avail. My user is added to the 'dialout' group. The red charging indicator LED is illuminated. Doing a USB probe, the Ringo does not show up. All of the cables that I have used are confirmed to work with other devices as well as the USB ports. I am at a loss.

EDIT. I have also tried running Arduino as Root, as well as different version of Arduino, none of which worked.

Re: Serial port not showing up.

Posted: Sat Aug 15, 2015 1:23 am
by kreiggers
Same issue here. OSX 10.10.4, FTDI drivers installed, but not getting anything when programmer + powered-on Ringo is plugged in. Nothing under /dev and nothing showing in Arduino IDE.

Re: Serial port not showing up.

Posted: Sat Aug 15, 2015 4:18 pm
by Kevin
Sorry to hear the troubles with getting the programming port to show. Here are a few things I can suggest or clarify.

-Whether Ringo is plugged into the programmer or not shouldn't have any effect on having the serial port show up. A few seconds after you plug in the programmer, you should see a serial port show up in the Arudino IDE regardless of whether Ringo is plugged in or not, or whether he is turned on or off.

-I have had the experience where the Arduino IDE itself didn't want to show the serial port even though the computer made it available (so the computer's OS sees the serial port, but Arduino doesn't show it for some reason). I believe the Arduino IDE is based on Java, and I did see something a long time ago about updating Java. When this has happened to me, usually re-starting the Arduino IDE or just giving it some time (a couple minutes) caused the serial port to come back up.

Here are a couple links I found which seem to discuss similar issues. Seems like the responses are mostly driver related. They may be of use:

-All USB cables (as far as I know) have pins for data and power. I believe it is a core part of the USB specification. It is certainly possible that a given cable is bad, but I'm not aware of a particular kind of cable not being compatible. As far as I know, all USB A to Mini-B cables should be wired identically.

-The programmer has a chip from a company called FTDI, and this chip has USB on one side, and a serial port on the other side (which actually connects to Ringo).

-I think the first step is to determine that you are getting some sort of USB connection to the host computer. On windows for example, if you plug in the programmer via USB and you get that "da-dunk" sound like when you connect other USB devices, then the FTDI chip is working, the cable to your computer is working, and your computer is at least seeing something there. That would tell me that the hardware itself is functional.

-If you have no response what so ever from your computer, that could indicate a problem with the programmer or the USB cable between your computer and the programmer. To date we haven't found any non working programmers so they appear to be pretty solid. You can also try plugging to a different USB port on your computer.

-I wonder if there are any apps you could download to tell you whether your computer sees a device connected to USB? I haven't looked, but it may be worth some digging if anyone wants to see what's out there. It could be a tool to determine if the computer even sees anything on the USB port.

-The FTDI chip on the programmer is the same part used on the Sparkfun Red Board. The Red Board is their own version of the Arduino Uno board. They are using the same FTDI chip in the same way, so it may be worth having a look around Sparkfun's forum and support pages for the Red Board.

Here are some links from SF's FTDI Installation Tutorial:
Mac: ... rivers/mac
Win: ... --in-depth

-If you get any response from your computer at all, that tells me the hardware is functional and it is now likely down to a configuration or driver issue on the host PC. We ran into a few issues when our beta testers where getting set up:

1) On Mac, there was some issue with the driver not installing if the user didn't have administrator access to the computer. Not sure the details on this, but it was apparently resolved. There is a link to a rather lengthy document from FTDI on the drivers page on our website under the Mac section. It is lengthy instructions on how to install the FTDI drivers on Mac. I don't know much about Mac, but it may be worth carefully going over the details in that procedure.

2) On Windows, if the FTDI driver isn't installed before first plugging in the programmer board, Windows tends to want to associate its own driver with the board which causes problems. In this case you may need to uninstall and re-install the FTDI driver to get it to properly associate.

I'll keep an eye on the thread here and see what you're able to work out. I do have a technical contact at FTDI who has been really helpful in the past so if an issue persists, I can contact him this week and work out a solution.

If you do work out a solution, please let us know.

Sorry for the hassle! We'll get everyone running eventually.

Re: Serial port not showing up.

Posted: Sat Aug 15, 2015 6:41 pm
by weirdbal
I just got the new USB cable I ordered and still no luck. I tried two different Windows 7 PCs and a Mac with the same results. None of them make any noise or give any indication a device is connected when it is plugged in.

Re: Serial port not showing up.

Posted: Sat Aug 15, 2015 7:05 pm
by MTBguy
Still not getting the Ringo to show up.

This is my USB devices without Ringo plugged in

Same with Ringo plugged in.

and this is a USB mic plugged into the same USB port with the same cord. Notice how there is an extra line.

Unfortunately, I do not have another Arduino to try out. I am thinking that the programming board may be bad.Does anyone have any idea?

Re: Serial port not showing up.

Posted: Sat Aug 15, 2015 7:49 pm
by Kevin
weirdbal and MTBguy-

I think the programmer may be suspect at this point as you've tried it on so many machines. Can you guys take high res photos of the surface of the programmer? Or can you visually inspect a couple things under a magnifying glass? I want to make sure there isn't a solder flaw we missed.

Check the USB port - inspect the leads as they touch the board and make sure none have solder bridges (where solder touches between two pins). This is very rare and they should have all been inspected and tested, but it's worth a look. Also look at the 5 components to the right of the USB port (C2, C3, D1, R2, R3). Finally have a look at the main IC on the board - make sure you don't see any solder bridges, that all the pins connect to the board, and also check the polarity dot on the part - it's a little dent in the IC package. The dent should be toward the inner side of the board rather than the outer side.

If you keep having issues over the weekend, I can send you out new programmers on Monday that I'll verify myself are working on several computers. That'll either solve the problem or rule out the board as the problem.

Thanks for the cooperation. If we've got something strange happening on the programmers we certainly want to know asap. We've sent out quite a few and this is the first I've heard of the issue not being solved by software or drivers.


Re: Serial port not showing up.

Posted: Sat Aug 15, 2015 7:53 pm
by Kevin
trent wrote:I am running PC Windows 8.1. And have also noticed that the charge light comes on with the direct USB connection, but not through the programming board.

Trent- Is the little black jumper still installed on your programmer? The pins that poke off the board should have the black jumper in place, this allows charging through the programming board (it just connects the USB 5v line through the board to the programming pins at the end). If that jumper is missing you won't get charging through the programmer.