OS X 10.10 Driver/Port Issues

Ringo setup, hardware, basic programming. User to user support.
Posts: 5
Joined: Fri Sep 18, 2015 2:28 am

Re: OS X 10.10 Driver/Port Issues

Postby darrshar » Fri Oct 23, 2015 7:14 am


Arduino 1.0.5 compiles and uploads, but not seamlessly. Sometimes it takes a few attempts at uploading. It lists the port as tty.

I can't upload at all from Arduino 1.6.5, which only lists the port as cu. I get the errors in the previous post. When trying to upload, the programmer either doesn't blink, blinks once, or blinks a lot like it is uploading but then hangs.

Thanks for replying

Posts: 15
Joined: Sat Oct 17, 2015 9:57 pm

Re: OS X 10.10 Driver/Port Issues

Postby jedward » Fri Oct 23, 2015 10:16 pm

I suddenly experienced a day and a half of "programmer is not responding" error messages. I could write and compile new code but could not get it into Ringo. This message appeared doggedly after consistently receiving good verifying and compiling results.

In frustration, I uninstalled the FDTI driver [using Terminal] and the Arduino 1.6.5 app, along with all the Ringo libraries.

I then did a fresh install, and for one run of the 'Ringo_PreLoaded_Behaviors' I could both verify and upload. Then I got the dreaded "programmer is not responding" error message again – no matter how many re-boots and checks on the Tool menu of my port and board settings.

Then I saw Kevin's 10/22 post about ±3-blinks on the board's [nonTx/Rx] leds, and did a deliberate programming cable disconnect and reconnect. All is working again.

Damn the small stuff!!!

I am making some progress toward my modified DriveWithRemote goal. See separate thread: "Ringo Code Share" > "Drive by Remote - expanded".

Posts: 10
Joined: Tue Sep 15, 2015 3:37 pm

Re: OS X 10.10 Driver/Port Issues

Postby mikasami » Tue Dec 08, 2015 4:46 am

Programming ringo didn't use to be problem
but now I suddenly can't program anymore, I keep getting a programmer not responding error.

I tried to disconnect and connect the cable several times. even letting it rest for a while but it still doesn't work.


Who is online

Users browsing this forum: No registered users and 9 guests