Programmer adapter and driver. Help!

Ringo setup, hardware, basic programming. User to user support.
Albin Dalbert
Posts: 2
Joined: Wed Sep 23, 2015 3:51 pm

Programmer adapter and driver. Help!

Postby Albin Dalbert » Wed Sep 23, 2015 3:56 pm

Hi!

I have a Problem-
I have conect my programmer adapter to my computer before I even knew it exist a driver

What should I do to fix it!

Thankfull for answer

Albin Dalbert
Posts: 2
Joined: Wed Sep 23, 2015 3:51 pm

Re: Programmer adapter and driver. Help!

Postby Albin Dalbert » Thu Sep 24, 2015 2:28 pm

I mean now I have install the driver but I cant do anything with my ringo becuse I have conect my adapter before

Kevin
Posts: 175
Joined: Tue Jul 28, 2015 12:56 am

Re: Programmer adapter and driver. Help!

Postby Kevin » Fri Sep 25, 2015 8:42 pm

Albin,

You may still be okay. We suggest installing the driver first because some computers (especially Windows) tends to associate the programmer with the wrong driver.

Go ahead and install the correct driver, then connect the programmer. If it is happy, you'll see a new entry appear in the Arduino Tools>Port drop down when you connect the programmer (it may take 15 seconds or so to show up after connecting).

Are you seeing a new item appear in your "Tools>Port" drop down?

If that doesn't work, let me know what OS you're using and we'll figure out how to uninstall the other driver.

Thanks,
-Kevin

Kevin
Posts: 175
Joined: Tue Jul 28, 2015 12:56 am

Re: Programmer adapter and driver. Help!

Postby Kevin » Fri Sep 25, 2015 10:48 pm

Albin,

I noticed your email from this afternoon that you hadn't received a response. I responded yesterday and again today - but I wanted to post here also in case the emails aren't showing on your end. Here's the response from today...

Let's try a few things. You may still be okay.

1) Unplug the USB from the programmer, then inside Arduino, look at the Tools>Port drop down. Note how many entries are listed. Now plug the USB back in and wait about 10 seconds and check the Tools>Port drop down again. You should see a new entry appear. If a new entry appears, then your drivers are setup okay.

2) Make sure you've selected "Arduino Fio" in the Tools>Board drop down.

3) Make sure Ringo is turned on, and make sure the programming cable is connected to all 10 of Ringo's pins (not just the top row of pins).

Let me know if that solves anything. Also, what operating system is on your computer?

Thanks,
-Kevin

kellyk413
Posts: 3
Joined: Wed Aug 12, 2015 12:51 pm

Re: Programmer adapter and driver. Help!

Postby kellyk413 » Sat Sep 26, 2015 3:36 am

hello, im getting this error when trying to compile the prelaoded behaviers

Arduino: 1.6.5 (Windows XP), Board: "Arduino Fio"

Cannot run program "{runtime.tools.avr-gcc.path}\bin\avr-g++" (in directory "."): CreateProcess error=2, The system cannot find the file specified

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.


Who is online

Users browsing this forum: No registered users and 1 guest