OSX10.10—JavaRunTimeEnvironment Problem

Ringo setup, hardware, basic programming. User to user support.
jedward
Posts: 16
Joined: Sat Oct 17, 2015 9:57 pm

OSX10.10—JavaRunTimeEnvironment Problem

Postby jedward » Sat Oct 24, 2015 4:03 am

This tied me up for 5 or 6 hrs. I use 2 Macs in different locations to work on Ringo. The iMac on my desk does NOT evidence this problem, but my MacBook [portable, obviously] did: Suddenly yesterday whenever I tried to open Arduino.app directly or a sketch file, my MacBook displayed "Cannot open Java RunTime Environment". The files I was trying to open were all ones I had previously compiled, uploaded and successfully ran in Ringo.

After hours of searching, I determined that the JavaAppletPlugin had been automatically updated by Java/Oracle from 1.8.0_60 to 1.8.0_65 on my MacBook but not on my iMac. This is the ONLY DIFFERENCE I could find.

I reinstalled Java, Arduino, FDTIDriver, etc. Lo and behold, Arduino.app opened and seemed normal. I QUIT and tried to open another sketch — and got the "Cannot open Java RunTime Environment" error again.

Then I remembered that after quitting the first sketch, I moved the app to my Applications folder, which seemed a logical place for it. I moved the app back to the Downloads folder, it worked. Then to Documents>Arduino, and it also worked. So, presently the Arduino.app launches OK from anywhere but the Applications folder.

HUH??? I dont plan to upgrade the Javaplugin on my iMac!!

Kevin
Posts: 180
Joined: Tue Jul 28, 2015 12:56 am

Re: OSX10.10—JavaRunTimeEnvironment Problem

Postby Kevin » Sat Nov 21, 2015 2:35 am

jedward,

Thanks for the notes on this. This is good to know. I have an old 1st generation MacBook, and I have the same problem on that. I don't use it much for anything as it's old enough I can't even put the most recent OS X on it (WHY would Apple do this?!?!!?). Anyway, when I click Arduino from the dock, I would either get nothing at all or I'd get something about Java. I found some notes on the Arduino form from others who suggested making sure Java is updated. Apparently *not* updated is better in some cases.

In any event, it's interesting that it doesn't play well from the Applications folder. Not sure what effect that would have at all but apparently it's important.

Have you ever done a "repair file permissions" on your Mac? There's a free utility called OnyX that will do this. Apparently sometimes on any given Mac, the background Unix file permissions can get screwy and this fixes them. Supposed to fix random issues like this. I run all the OnyX tools on my Macs a couple times a year. Just a suggestion.

OnyX link: http://www.titanium.free.fr/onyx.html

Good luck and sorry you had the hassle. Thanks for sticking in there and solving it. :)


Who is online

Users browsing this forum: No registered users and 3 guests