OS X 10.11 (El Capitan) driver question

Ringo setup, hardware, basic programming. User to user support.
abe
Posts: 3
Joined: Wed Dec 23, 2015 8:58 pm

OS X 10.11 (El Capitan) driver question

Postby abe » Wed Dec 23, 2015 9:10 pm

Hello,

I have a question concerning the FTDI driver on Mac OS X 10.11 (El Capitan)
With El Capitan I did not have to install the FTDI drivers for my SparkFun 'Digital Sandbox' board, it seems to work fine with the Apple driver. However with Ringo I'm getting the 'programmer is not responding' error (this is my first time plugging in the Ringo ever)

Code: Select all

avrdude: stk500_recv(): programmer is not responding


Question: Do I really need to install the FTDI driver on El Capitan? If so, what should be the process? Should I follow this thread (for OS X 10.10): http://forum.plumgeek.com/viewtopic.php?f=9&t=679 ?

Thanks for the help.
Season's Greetings to you all!

Abe

PeteM
Posts: 13
Joined: Fri Aug 07, 2015 8:02 pm

Re: OS X 10.11 (El Capitan) driver question

Postby PeteM » Wed Dec 23, 2015 9:22 pm

Before you go further make sure the switch on the programmer board is in ON position.

abe
Posts: 3
Joined: Wed Dec 23, 2015 8:58 pm

Re: OS X 10.11 (El Capitan) driver question

Postby abe » Thu Dec 24, 2015 4:28 am

@PeteM: thanks for the quick feedback.
As it turns out, the Apple FTDI driver on El Capitan worked for me.

My problem was apparently related to the order everything needs to be connected:

1. Turn on Ringo
2. Connect Ringo to programming board
3. Connect programming board to Mac
4. Open Arduino IDE
5. Deploy code to Ringo

I'm not 100% certain about that but I can confirm that I was able to push code to Ringo using the standard Apple FTDI driver in El Capitan.

Regards,
Abe


Return to “Ringo Basics”

Who is online

Users browsing this forum: No registered users and 1 guest