Unreliable remote

Ringo setup, hardware, basic programming. User to user support.
davek
Posts: 2
Joined: Fri Dec 25, 2015 8:13 am

Unreliable remote

Postby davek » Fri Dec 25, 2015 8:18 am

Hi,

just got Ringo working for my son for Crimbo. However, the remote seems to be really unreliable and hit and miss, tried changing the battery, but still the same problem. It kind of works for a couple of pushes then stops working for about 10 seconds then starts again, I only appear to get one valid push of the button in between non working pushes. Anyone experience the same problem?


Thanks

David

Kevin
Posts: 127
Joined: Tue Jul 28, 2015 12:56 am

Re: Unreliable remote

Postby Kevin » Tue Dec 29, 2015 1:38 am

Hello davek,

We've just posted yesterday and update to the Pre-Loaded behaviors and also the Base Sketch which significantly improves the remote functionality. Some units were really hit and miss and others worked fine. I finally tracked it down to the way the code was re-enabling interrupts when a packet was received. In theory the change I made shouldn't have had any real effect, though it did seem to make those robots much improved in reception.

Here's the link to the Kickstarter update we posted with the new links:
https://www.kickstarter.com/projects/pl ... ts/1453953

Try loading up these new behaviors and read over the notes in the update. I think you'll find it much more responsive. Let me know how it goes.

Thanks,
-Kevin

davek
Posts: 2
Joined: Fri Dec 25, 2015 8:13 am

Re: Unreliable remote

Postby davek » Fri Jan 01, 2016 1:06 pm

Hi Kevin,

many thanks for the reply and the code tweak. That did the trick :)



Thanks again.

David


Who is online

Users browsing this forum: No registered users and 1 guest