FTDI Driver not installing

Ringo setup, hardware, basic programming. User to user support.
angerbam
Posts: 3
Joined: Sat Dec 26, 2015 2:14 am

FTDI Driver not installing

Postby angerbam » Sat Dec 26, 2015 2:28 am

Ringo Robot driver Install problems.

I have run the device driver install (CDM v2.12.06 WHQL Certified) logged in as admin, running the exe as admin, and it hangs indefinitely after I accept and the installer message states "the drivers are now installing". "Please wait while the drivers install. This may take some time to complete". Same result after multiple tries.

I have installed the Arduino 1.6.7 windows driver successfully - fyi.

Running Windows 7, 64 bit , SP1.

I have NOT plugged in or connected Ringo to my computer.

Is there a way I can manually install the drivers? Can I alternately install drivers off the FTDIchip.com site?

angerbam
Posts: 3
Joined: Sat Dec 26, 2015 2:14 am

Re: FTDI Driver not installing

Postby angerbam » Sat Dec 26, 2015 3:56 pm

I guess it wasn't hanging, but after more than an hour, the device driver install wizard gives a message: "Cannot Complete the Device Driver Installation Wizard. Errors were encountered - see status column" and the Status column just says: Install failed next t o the driver names: FTDI CDM Driver Package -Bus/D2XX Driver (07/10/2015 2.12.06), and FTDI CDM Driver Package - VCP Driver (07/10/2015 2.12.06)

Kevin
Posts: 129
Joined: Tue Jul 28, 2015 12:56 am

Re: FTDI Driver not installing

Postby Kevin » Tue Dec 29, 2015 1:35 am

Hello angerbam,

I was thinking the installer was an executable that didn't involve a "wizard" but it's been a while since I actually installed them. I would suggest trying to install the ones right from the FTDI site.

You want the "VCP" drivers. (The D2XX and D3XX are apparently for a different FTDI chip).

I've not heard of anyone unable to actually install them, but some people had various problems with the 2.12 drivers. If you scroll down the page you can find the 2.10 version, which solved the problems those people were having. Maybe give those a try. Here's the link:
http://www.ftdichip.com/Drivers/VCP.htm

Let me know how it goes.

Thanks,
-Kevin

angerbam
Posts: 3
Joined: Sat Dec 26, 2015 2:14 am

Re: FTDI Driver not installing

Postby angerbam » Wed Dec 30, 2015 2:10 am

Thanks for the reply. Well, for whatever reason, and after many failures, the install worked fine today - guess there was a federal holiday exclusion in the code. We're off to the config races!!


Who is online

Users browsing this forum: No registered users and 1 guest