USB drivers discovery

Ringo setup, hardware, basic programming. User to user support.
aEtherEater
Posts: 3
Joined: Mon Aug 24, 2015 12:00 am

USB drivers discovery

Postby aEtherEater » Mon Aug 24, 2015 12:20 am

Hello Plum Geek community!
I was in the middle of getting started with my new Ringos and ran into a small issue with the FTDI drivers not completely initiating the serial port. I've ran into the same issue when I went to use an Arduino Nano I have and found a solution by using older version drivers. I am using windows 7 x64 by the way and have all 3 FTDI driver packages installed. Those are versions 2.12.06, 2.10.00, and 2.08.30. In my particular case, uninstalling all versions of the FTDI drivers and installing 2.12.06 first, then 2.08.30 were not solving the issue, even when I would go into device manager and assign the driver manually. It was after completing the installation of version 2.10.00 that the serial port completely resolved in my device manager window. I hope this helps anyone who runs into issues similar to mine with their Ringo!

TLDR;
I used 2.10.00 drivers on this page: http://www.ftdichip.com/Drivers/VCP.htm on a win 7 64-bit system, to get my Ringo's to read properly.

Kevin
Posts: 180
Joined: Tue Jul 28, 2015 12:56 am

Re: USB drivers discovery

Postby Kevin » Wed Aug 26, 2015 3:22 am

aEtherEater-

Thanks so much for sharing this! You're the third person I've come across who had issues but going back to 2.10.00 specifically solved the problem. I have a technical contact at FTDI and as soon as I have a chance I'll bring this up with them. Sounds like an issue that should be easily fixed in a future release of the driver. I know the low level processor code pretty well, but when it comes to drivers and desktop OS's, it's all voodoo and magic smoke to me. :)

-Kevin

aEtherEater
Posts: 3
Joined: Mon Aug 24, 2015 12:00 am

Re: USB drivers discovery

Postby aEtherEater » Fri Aug 28, 2015 2:54 am

I'm glad I could help.

klancer00
Posts: 1
Joined: Wed Sep 09, 2015 3:07 am

Re: USB drivers discovery

Postby klancer00 » Wed Sep 09, 2015 3:13 am

This sounds like the same problem I'm having... for someone less tech savvy , can you tell me how to uninstall the drivers and reinstall 2.10.00?

aEtherEater
Posts: 3
Joined: Mon Aug 24, 2015 12:00 am

Re: USB drivers discovery

Postby aEtherEater » Sun Sep 20, 2015 6:58 pm

Are you using Ringo on a windows system?

If you are, you can just run the 2.10 installer and it should detect the drivers and uninstall them. Re-run the installer you should be set.


Who is online

Users browsing this forum: No registered users and 13 guests