Arduino's Tools>Port does NOT show USB->Serial Port

Ringo setup, hardware, basic programming. User to user support.
Posts: 1
Joined: Sun Jun 05, 2016 5:32 am

Arduino's Tools>Port does NOT show USB->Serial Port

Postby felipenasc » Sun Jun 05, 2016 5:53 am

Hi there,

I have followed the instructions:
1) I Installed FTDI Driver
2) Rebooted
3) Downloaded and installed Arduino 1.6.5
4) Installed Ringo's libraries
5) I turned Ringo on (blue light keeps blinking)
6) I connected Ringo to programming interface, and programming interface to USB, and USB to computer (red light turns on)
(I also tried connecting first and then turnning it on)
7) Selected Arduino Fio

But Arduino's Tool>Port menu does not list USB-Serial port. It looks like the driver is not working. I have a Mac 10.11.1 , the driver is FTDIUSBSerialDriver_v2_3.dmg

I can see, in my Terminal, that /Library/Extensions/ does have the FTDIUSBSerialDriver.kext folder there.

I tried
> kextstat | grep FTDI
but nothing is printed out.

I tried
>sudo kextload /Library/Extensions/FTDIUSBSerialDriver.kext
but still no USB->Serial port

There is no USB->serial port in /dev (not cu.usbxxxxxxx nor tty.usbxxxxxxx)....

Don't know what to do here anymore.

Any help is appreciated.

Posts: 3
Joined: Wed Aug 17, 2016 1:34 pm

Re: Arduino's Tools>Port does NOT show USB->Serial Port

Postby ronaldroe » Wed Aug 17, 2016 1:40 pm

I had the same issue. It ended up being the USB cable I was using. Quick drive to the store and $7 later, no problem.

Posts: 180
Joined: Tue Jul 28, 2015 12:56 am

Re: Arduino's Tools>Port does NOT show USB->Serial Port

Postby Kevin » Fri Aug 19, 2016 1:32 am

Hello Felipe,

It does sound like a cable perhaps. I can see you are familiar with the inner workings of how the Mac registers the device. I haven't tried these calls myself but it does sound like you should be getting a port to show up. Can you maybe try with a different cable and let me know if that solves it?

We haven't had many problems with Mac. Most of the driver/programmer issues that have come up are Windows based. You can also contact me through the Contact form on the main website and we can go back and forth there. I do have a direct contact to a knowledgeable developer at FTDI that we can ask if the problem persists. We'll get it figured out.


Who is online

Users browsing this forum: No registered users and 13 guests